http://acm.hdu.edu.cn/showproblem.php?pid=1051
Wooden Sticks(护眼模式)
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 18540 Accepted Submission(s): 7556
Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output
2
1
3
Source
Asia 2001, Taejon (South Korea)
题意:
给定一堆需要加工的乱序的木头,目前加工的这一根的长度和重量比之前加工的那一根都大,就不需要升级机器,
升级机器花费的时间是一分钟。问最后至少需要花费多少分钟。
思路: LIS 和 dp 的结合,很基础的题了,今天第二天学习这个算法(其实也不算新的学习),感觉还是需要慢慢的去自己进行演示,理解。
Code:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int MYDD=1103+5e3;
struct Q {
int length;//长度
int weight;//密度
} wooden[MYDD];
int dp[MYDD];//当前木头之前的时间数
bool cmp(Q x,Q y) {
if(x.length!=y.length) return x.length<y.length;
return x.weight<y.weight;
}
int main() {
int TT;
scanf("%d",&TT);
while(TT--) {
int n,i,j;
memset(dp,0,sizeof(dp));//dp[]的初始化
scanf("%d",&n);
for(j=1; j<=n; j++)
scanf("%d%d",&wooden[j].length,&wooden[j].weight);
sort(wooden+1,wooden+n+1,cmp);
for(j=1; j<=n; j++)
for(i=1; i<=j; i++)
if(wooden[j].weight<wooden[i].weight)
if(dp[j]<dp[i]+1) dp[j]=dp[i]+1;
sort(dp,dp+MYDD);//寻找最大值
printf("%d\n",dp[MYDD-1]+1);//dp[]初始化是 0
}
return 0;
}
转载请注明原文地址: https://ju.6miu.com/read-1279096.html