Gray code
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 1216 Accepted Submission(s): 664
Problem Description
The reflected binary code, also known as Gray code after Frank Gray, is a binary numeral system where two successive values differ in only onebit (binary digit). The reflected binary code was originally designed to prevent spurious output from electromechanical switches. Today, Gray codes are widely used to facilitate error correction in digital communications such as digital terrestrial television and some cable TV systems.
Now , you are given a binary number of length n including ‘0’ , ’1’ and ‘?’(? means that you can use either 0 or 1 to fill this position) and n integers(a1,a2,….,an) . A certain binary number corresponds to a gray code only. If the ith bit of this gray code is 1,you can get the point ai.
Can you tell me how many points you can get at most?
For instance, the binary number “00?0” may be “0000” or “0010”,and the corresponding gray code are “0000” or “0011”.You can choose “0000” getting nothing or “0011” getting the point a3 and a4.
Input
The first line of the input contains the number of test cases T.
Each test case begins with string with ‘0’,’1’ and ‘?’.
The next line contains n (1<=n<=200000) integers (n is the length of the string).
a1 a2 a3 … an (1<=ai<=1000)
Output
For each test case, output “Case #x: ans”, in which x is the case number counted from one,’ans’ is the points you can get at most
Sample Input
2
00?0
1 2 4 8
????
1 2 4 8
Sample Output
Case #1: 12
Case #2: 15
Hint
https://en.wikipedia.org/wiki/Gray_code
http://baike.baidu.com/view/358724.htm
Author
UESTC
Source
2015 Multi-University Training Contest 7
题意:一串只包含字符'0' '1' '?' 然后?可是是1或0 问之后形成的二进制串对应的格雷码 中为1的位所对应的a数组的值的最大加和
百度弄懂格雷码和二进制串之间的关系 例如一二进制串 10101 其所对应的格雷码 第一位就是二进制串的第一位 第二位之后就是 二进制串的该位与前一位的异或结果
所以其所对应的格雷码就是 11111
之后也意识到是dp了 可是这么简单的dp都不会写 也是对自己无语了 还是看了官方题解又写的 渣渣啊真是
#include <iostream>
#include<cstdio>
#include<cstring>
#define maxn 200020
using namespace std;
typedef long long ll;
int a[maxn];
char s[maxn];
int dp[maxn][2];
int main()
{
int t,cnt=0;
scanf("%d",&t);
while(t--)
{
scanf("%s",s+1);
s[0]='0';
int lens=strlen(s);
for(int i=1;i<lens;++i)
scanf("%d",&a[i]);
memset(dp,0,sizeof(dp));
dp[0][0]=0,dp[0][1]=-1;
for(int i=1;i<lens;++i)
{
if(s[i]=='0')
{
if(s[i-1]=='0')
dp[i][0]=dp[i-1][0];
else if(s[i-1]=='1')
dp[i][0]=dp[i-1][1]+a[i];
else if(s[i-1]=='?')
dp[i][0]=max(dp[i-1][1]+a[i],dp[i-1][0]);
dp[i][1]=-1;
}
else if(s[i]=='1')
{
if(s[i-1]=='1')
dp[i][1]=dp[i-1][1];
else if(s[i-1]=='0')
dp[i][1]=dp[i-1][0]+a[i];
else if(s[i-1]=='?')
dp[i][1]=max(dp[i-1][0]+a[i],dp[i-1][1]);
dp[i][0]=-1;
}
else if(s[i]=='?')
{
if(s[i-1]=='0')
{
dp[i][1]=dp[i-1][0]+a[i];
dp[i][0]=dp[i-1][0];
}
else if(s[i-1]=='1')
{
dp[i][0]=dp[i-1][1]+a[i];
dp[i][1]=dp[i-1][1];
}
else if(s[i-1]=='?')
{
dp[i][0]=max(dp[i-1][0],dp[i-1][1]+a[i]);
dp[i][1]=max(dp[i-1][1],dp[i-1][0]+a[i]);
}
}
}
printf("Case #%d: %d\n",++cnt,max(dp[lens-1][0],dp[lens-1][1]));
}
return 0;
}
转载请注明原文地址: https://ju.6miu.com/read-1295203.html