绝对值排序
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 66696 Accepted Submission(s): 32233
Problem Description
输入n(n<=100)个整数,按照绝对值从大到小排序后输出。题目保证对于每一个测试实例,所有的数的绝对值都不相等。
Input
输入数据有多组,每组占一行,每行的第一个数字为n,接着是n个整数,n=0表示输入数据的结束,不做处理。
Output
对于每个测试实例,输出排序后的结果,两个数之间用一个空格隔开。每个测试实例占一行。
Sample Input
3 3 -4 2
4 0 1 2 -3
0
Sample Output
-4 3 2
-3 2 1 0
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;
bool cmp(int a, int b)
{
return abs(a)>abs(b);
}
int main()
{
int n,i;
while(cin>>n&&n)
{
int a[101];
memset(a,0,sizeof(a));
for(i=0; i<n; i++)
{
cin>>a[i];
}
sort(a,a+n,cmp);
cout<<a[0];
for(i=1; i<n; i++)
{
cout<<" "<<a[i];
}
cout<<endl;
}
return 0;
}
转载请注明原文地址: https://ju.6miu.com/read-1296161.html