Problem Description
Lweb has a string
S
.
Oneday, he decided to transform this string to a new sequence.
You need help him determine this transformation to get a sequence which has the longest LIS(Strictly Increasing).
You need transform every letter in this string to a new number.
A
is the set of letters of
S
,
B
is the set of natural numbers.
Every injection
f:A→B
can be treat as an legal transformation.
For example, a String “aabc”,
A={a,b,c}
, and you can transform it to “1 1 2 3”, and the LIS of the new sequence is 3.
Now help Lweb, find the longest LIS which you can obtain from
S
.
LIS: Longest Increasing Subsequence. (https://en.wikipedia.org/wiki/Longest_increasing_subsequence)
Input
The first line of the input contains the only integer
T,(1≤T≤20)
.
Then
T
lines follow, the i-th line contains a string
S
only containing the lowercase letters, the length of
S
will not exceed
105
.
Output
For each test case, output a single line "Case #x: y", where x is the case number, starting from 1. And y is the answer.
Sample Input
2
aabcc
acdeaa
Sample Output
Case #1: 3
Case #2: 4
题意:智障题,统计一个只含小写字母的字符串里有多少种不同的字符
AC代码如下:
#include<iostream>
#include <string>
using namespace std;
int main()
{
int t,i;
int n;
int num;
int a[26];
int k = 1;
string s;
cin >> t;
while (t--)
{
for (i = 0; i < 26; i++)
{
a[i] = 1;
}
num = 0;
cin >> s;
n = s.size();
for (i = 0; i < n; i++)
{
if (a[int(s[i]) - 'a'])
{
a[s[i] - 'a'] = 0;
num++;
}
}
cout<< "Case #"<<k++<<": "<< num << endl;
}
return 0;
}
转载请注明原文地址: https://ju.6miu.com/read-1298070.html