win上面配置本地MySQL主从

    xiaoxiao2026-10-03  5

    含义: MySQL的主从复制是一个异步的复制过程,从一个mysql(Master,主数据库)复制到另一个mysql(Slave,从数据库) 原理: 主数据库-----数据更新------>中继日志-----Io线程------->二进制日志-------Sql线程----->写入从数据库 好处: 主从服务器的设置增加了健壮性。主服务器出现错误时,可以切换到从服务器。 可以处理客户查询的负荷,得到更好的客户响应时间(要求读写分离) 执行备份,不会干扰主服务器 使用不同的读节点,减轻单数据库的压力 安装一个独立的mysql 1.首先在D盘建一个目录(mysql5.6.24),在这个目录下把解压好的东西放在里面 (解压的东西在360云盘-文档-学习-mysql安装包-32位的) 2.修改mysql配置 计算机-属性-高级系统配置-环境变量-PATH 在后面加 :D:\mysql5.6.24 3.在D盘mysql5.6.24下创建my.ini [mysqld] port=3307 basedir=D:\mysql5.6.24 datadir=D:\mysql5.6.24\data log_bin = mysql-bin server_id = 2 relay_log = mysql-relay-bin log_slave_updates = 1 read_only = 1 或者 [mysqld] port=3307 basedir=D:\Mysql_Server_5.6.24 datadir=D:\Mysql_Server_5.6.24\data #日志配置 log-error=D:\MysqlServer5.6\logs\error.log  log=D:\MysqlServer5.6\logs\mysql.log  long_query_time=2  log-slow-queries=D:\MysqlServer5.6\logs\slowquery.log  4.使用管理员打开cmd 进入d盘mysql5.6.24下的bin下 mysqld -install 5. net start mysql 启动mysql服务 Net stop mysql 停止mysql服务 安装完之后开始,进行主从复制 配置mysql主从复制 保证cmd服务器已开启 在小绿叶里新建一个连接(端口为3307,密码不用) 在这个连接里新建一个数据库(与主数据库一致,表名也要一致) 打开主链接,点查询-新建查询,执行下面的语句 flush privileges; GRANT REPLICATION SLAVE,RELOAD,SUPER ON *.* TO mysql_backup@'%' IDENTIFIED BY '123456'; 然后打开你的mysql里的 mysql.ini 加下面两句话 server-id=1 log-bin=mysql-bin 重启apache,mysql 再下来,还是点开主链接,点击查询-新建查询,执行下面的语句 SHOW MASTER STATUS 会出来这个 用cmd开启服务(看上面) 再下来,点开新建的那个连接,点击查询-新建查询,执行下面的语句 CHANGE MASTER TO master_host = '127.0.0.1', master_user = 'mysql_backup', master_password = '123456', master_log_file = 'mysql-bin.000001', master_log_pos = 3696; //306改成107 会报错,执行停止从库的命令 #停止从库 Stop slave CHANGE MASTER TO master_host = '127.0.0.1', master_user = 'mysql_backup', master_password = '123456', master_log_file = 'mysql-bin.000001', master_log_pos = 3696; //306改成107 //启动从库 Start slave
    转载请注明原文地址: https://ju.6miu.com/read-1312568.html
    最新回复(0)