交换与路由练习(四、排错)

    xiaoxiao2021-03-26  9

    (1)要求:

    1. SW3 SW4之间启用Etherchannel。

    2.SW4SW6之间使用Routed port

    3.使用静态路由来沟通SW4SW6间的路由条目。

    4. vlan内和vlan间可以互通。

    一、实现方法

    (1)  SW3SW4之间启用Etherchannel。

    1.    修改原因:实验要求SW3 SW4之间SW3 SW4之间启用Etherchannel。

    2.    修改:已用PAgP协议,删除,然后在相同端口使用LACP协议,所以将原port-channel 1 no掉,然后使用协议LACP,再次动态启用Etherchannel。

    3.    修改代码:

    SW3(config)#no interface port-channel 1

    SW3(config)#end

    SW3#show etherchannel summary

    SW3#conf t

    SW3(config)#interface port-channel 1

    SW3(config-if)#exit

    SW3(config)#interface range f0/23-24

    SW3(config-if-range)#channel-group 1 mode active

    SW3(config-if-range)# switchport trunk encapsulation dot1q

    SW3(config-if-range)# sw mo tr

    SW3(config-if-range)#speed 100

    SW3(config-if)#exit

    SW3(config)#interface port-channel 1

    SW3(config-if)#duplex full

    SW3(config-if)#end

    SW4(config)#no interface port-channel 1

    SW4(config)#end

    SW4#show etherchannel summary

    SW4#conf t

    SW4(config)#interfaceport-channel 1

    SW4(config-if)#exit

    SW4(config)#interface range f0/23-24

    SW4(config-if-range)#channel-group1 mode active

    SW4(config-if-range)# switchporttrunk encapsulation dot1q

    SW4(config-if-range)# sw mo tr

    SW4(config-if-range)#speed 100

    SW4(config-if)#exit

    SW4(config)#interfaceport-channel 1

    SW4(config-if)#duplex full

    SW4(config-if)#end

    (2)  SW4和SW6之间使用Routed port

    1.    修改原因:实验要求SW4和SW6之间使用Routed port。

    2.     修改:关闭交换机SW4f0/1SW6f0/1的交换功能,并给SW4f0/1端口配置ip46.46.46.4,子网掩码为255.255.255.0;给SW6f0/1端口配置ip46.46.46.6,子网掩码为255.255.255.0

    (3)  使用静态路由来沟通SW4 SW6间的路由条目。

    1.    修改原因:实验要求使用静态路由来沟通SW4 SW6间的路由条目,而且要VLAN2、3和VLAN13、24之间进行通信。

    2.    修改:

    1因为要用静态路由来沟通SW4 SW6间的路由条目,所以先查看SW4和SW6的路由表,发现SW6已配好SW4 SW6间的路由条目,只需给SW4配置静态路由条目ip route192.168.2.0 255.255.255.046.46.46.6和ip route192.168.3.0 255.255.255.046.46.46.6。

    2为了使VLAN2、3和VLAN13、24之间进行通信,需要在SW4上配置VLAN13和24的SVI,在SW6上配置VLAN2和3的SVI。

    3.    修改代码:

    SW4(config)#int vlan 13

    SW4(config-if)# ip add 192.168.13.100 255.255.255.0

    SW4(config-if)#no shut

    SW4(config-if)#exit

    SW4(config)#int vlan 24

    SW4(config-if)# ip add 192.168.24.100 255.255.255.0

    SW4(config-if)#no shut

    SW4(config-if)#exit

    SW4(config)# ip route 192.168.2.0 255.255.255.046.46.46.6

    SW4(config)# ip route 192.168.3.0 255.255.255.046.46.46.6

    SW6(config)#int vlan 2

    SW6(config-if)# ip add 192.168.2.100 255.255.255.0

    SW6(config-if)#no shut

    SW6(config-if)#exit

    SW6(config)#int vlan 3

    SW6(config-if)# ip add 192.168.3.100 255.255.255.0

    SW6(config-if)#no shut

    SW6(config-if)#exit

    (4)  vlan内和vlan间可以互通。

    1.错误:

    1PC3的子网掩码有误。

    2PC4的网关有误。

    3PC5的网关与其IP不在同一网段。

    4有些交换机和交换机之间的trunk没有配置好,有的是没配置上,有的是只允许一个VLAN通过。

    5不是所有交换机上都配置了VLAN2、3、13和24。

    6不是所有交换机的连机端口都放入了相应VLAN,有放错VLAN的情况出现。

    2.错误代码:

     1SW1的f0/20只允许一个VLAN通过。

    SW1(config)#int f0/20

    SW1(config-if)#sw tr en dot1q

    SW1(config-if)#sw mo tr

    SW1(config-if)#sw tr all vlan 2

    SW1(config-if)#exit

    2SW5连机端口放错VLAN。

    SW5(config)#int f0/1

    SW5(config-if)#sw mo ac

    SW5(config-if)#sw ac vlan 13

    SW5(config-if)#exit

    SW5(config)#int f0/2

    SW5(config-if)#sw mo ac

    SW5(config-if)#sw ac vlan 24

    SW5(config-if)#exit

    3.修改原因:

    1实验要求vlan内和vlan间可以互通。

    2如果想vlan内和vlan间可以互通,则PC的IP地址和网关要在同一个网段,交换机的连机端口要放入相应VLAN,每个交换机上都要有所有VLAN,交换机与交换机之间的链路要为trunk模式且允许所有VLAN的包通过。

    4.修改:

    1PC的IP地址和网关在同一个网段。

    2交换机的连机端口放入相应VLAN。

    3每个交换机上都配置所有VLAN。

    4交换机与交换机之间的链路配置为trunk模式且允许所有VLAN的包通过。

    5.修改代码:

    SW*(config)# vlan 13

    SW*(config-vlan)#exit

    SW*(config)# vlan 24

    SW*(config-vlan)#exit

    SW*(config)# vlan 2

    SW*(config-vlan)#exit

    SW*(config)# vlan 3

    SW*(config-vlan)#exit

    SW1(config)#int f0/4

    SW1(config-if)#sw mo ac

    SW1(config-if)#sw ac vlan 24

    SW1(config)#intf0/20

    SW1(config-if)#nosw tr all vlan 2

    SW1(config-if)#swtr en dot1q

    SW1(config-if)#swmo tr

    SW1(config-if)#noshut

    SW5(config)#int f0/1

    SW5(config-if)#no sw ac vlan 13

    SW5(config-if)#sw mo ac

    SW5(config-if)# sw ac vlan 2

    SW5(config-if)#exit

    SW5(config)#int f0/2

    SW5(config-if)#no sw ac vlan 24

    SW5(config-if)#sw mo ac

    SW5(config-if)# sw ac vlan 3

    SW5(config-if)#exit

    SW*(config)#int f0/19

    SW*(config-if)# sw tr en dot1q

    SW*(config-if)#sw mo tr

    SW*(config-if)#exit

    分析

    (1)  当VLAN内部和VLAN间ping不通时,可检查每个交换机上是否都有设置该VLAN,若有未设置的,进行设置,若都设置了且还是ping不通,则检查PC的ip地址是否配置有问题和交换机之间的链路是否为trunk模式,且允许所有VLAN通过。每个PC上的IP和网关一定要在同一网段。

    (2)  一个聚合组只能用一个协议。mode on是静态模式,两边要都配on,默认是PAgP协议;active(主动)和passive(被动)是LACP协议,两边不能同时配passive,否则不通;auto和desirable是PAgP协议,两边不能同时配auto,否则不通。

    用showetherchannel summary查看状态时,当链路两端都是(SU)、端口处都是(P)的时候,链路聚合成功。

    (3)  大部分情况下,一个网段只有一个网关,特殊情况下(如网络双出口),则可以有两个或两个以上网关ip地址,但它们的ip地址要在同一网段且不能相同,同网段的PC的网关可以从中任意选取。

    要知道在拓扑中的哪个交换机上设置SVI(网关),设置什么网关,网关的ip地址是多少,就要先清楚拓扑中数据包的传输过程。

    假设将两个VLAN的SVI(192.168.13.100和192.168.24.100)设置在SW3上,但SW3上没有三层接口(SW3和SW4之间的聚合链路是二层),所以就算SW4上有到VLAN2和VLAN3的静态路由,也无法真正实现VLAN间通信。若偏要在SW3上配置SVI,则要像作业1一样,在SW3和SW4之间再建一个VLAN用于沟通。

    (4)  不能在SW3上创建VLAN2和VLAN3的SVI:

    因为在三层交换机上创建完SVI(虚拟三层端口)后相当于在交换机上直连了一个网段,这就导致了交换机两端有相同的网络(VLAN2),就出现了问题,路由将不知道应该往哪里走。

    (5)  路由器与三层交换机(处理速度快,因为有快速转发表)的区别:

    路由器可以互联各种网络(以太网、帧中继、点对点等),因为这些网络的IP层是一样的,但是再往下的数据链路层和物理层用的协议就不一样,就会有区别了。

    转载请注明原文地址: https://ju.6miu.com/read-650023.html

    最新回复(0)