1.题目描述:
Can you answer these queries?
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65768/65768 K (Java/Others) Total Submission(s): 15596 Accepted Submission(s): 3661
Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.
Notice that the square root operation should be rounded down to integer.
Input
The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2
63.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
Sample Input
10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8
Sample Output
Case #1:
19
7
6
Source
The 36th ACM/ICPC Asia Regional Shanghai Site —— Online Contest
Recommend
lcy | We have carefully selected several similar problems for you:
3308
2871
1542
3397
4046
2.题意概述:
一堆数组,一个操作M x y,如果M是0则对x ~ y区间内数全部开根号,如果M是1则询问区间a ~ b内的和
3.解题思路:
也是一个活活的线段树,一个可以优化的地方,一个数如果连续被开根号n次,当n趋于无穷时候,它的极限应该是趋近于1的,但是我没仔细考虑这个问题。应该可以优化一下。
4.AC代码:
#include <bits/stdc++.h>
#define INF 0x3f3f3f3f
#define maxn 100010
#define lson root << 1
#define rson root << 1 | 1
#define N 1111
#define eps 1e-6
#define pi acos(-1.0)
#define e exp(1.0)
using namespace std;
const int mod = 1e9 + 7;
typedef long long ll;
typedef unsigned long long ull;
struct tree
{
int l, r;
ll w;
} t[maxn << 2];
void pushup(int root)
{
t[root].w = t[lson].w + t[rson].w;
}
void build(int l, int r, int root)
{
t[root].l = l;
t[root].r = r;
if (l == r)
{
scanf("%lld", &t[root].w);
return;
}
int mid = l + r >> 1;
build(l, mid, lson);
build(mid + 1, r, rson);
pushup(root);
}
void update(int l, int r, int root)
{
if (t[root].l == t[root].r)
{
t[root].w = sqrt(1.0 * t[root].w);
return;
}
if (l <= t[root].l && t[root].r <= r && t[root].w == t[root].r - t[root].l + 1)
return;
int mid = t[root].l + t[root].r >> 1;
if (l <= mid)
update(l, r, lson);
if (r > mid)
update(l, r, rson);
pushup(root);
}
ll query(int l, int r, int root)
{
if (l <= t[root].l && t[root].r <= r)
return t[root].w;
int mid = t[root].l + t[root].r >> 1;
ll ans = 0;
if (l <= mid)
ans += query(l, r, lson);
if (r > mid)
ans += query(l, r, rson);
return ans;
}
int main()
{
#ifndef ONLINE_JUDGE
freopen("in.txt", "r", stdin);
freopen("out.txt", "w", stdout);
long _begin_time = clock();
#endif
int n, m, kase = 0;
while (~scanf("%d", &n))
{
printf("Case #%d:\n", ++kase);
build(1, n, 1);
scanf("%d", &m);
while (m--)
{
int a, b, c, x, y;
scanf("%d%d%d", &a, &b, &c);
x = min(b, c);
y = max(b, c);
if (a == 0)
update(x, y, 1);
else
printf("%lld\n", query(x, y, 1));
}
puts("");
}
#ifndef ONLINE_JUDGE
long _end_time = clock();
printf("time = %ld ms.", _end_time - _begin_time);
#endif
return 0;
}
转载请注明原文地址: https://ju.6miu.com/read-675463.html