How many ways
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 4979 Accepted Submission(s): 2957
Problem Description
这是一个简单的生存游戏,你控制一个机器人从一个棋盘的起始点(1,1)走到棋盘的终点(n,m)。游戏的规则描述如下:
1.机器人一开始在棋盘的起始点并有起始点所标有的能量。
2.机器人只能向右或者向下走,并且每走一步消耗一单位能量。
3.机器人不能在原地停留。
4.当机器人选择了一条可行路径后,当他走到这条路径的终点时,他将只有终点所标记的能量。
如上图,机器人一开始在(1,1)点,并拥有4单位能量,蓝色方块表示他所能到达的点,如果他在这次路径选择中选择的终点是(2,4)
点,当他到达(2,4)点时将拥有1单位的能量,并开始下一次路径选择,直到到达(6,6)点。
我们的问题是机器人有多少种方式从起点走到终点。这可能是一个很大的数,输出的结果对10000取模。
Input
第一行输入一个整数T,表示数据的组数。
对于每一组数据第一行输入两个整数n,m(1 <= n,m <= 100)。表示棋盘的大小。接下来输入n行,每行m个整数e(0 <= e < 20)。
Output
对于每一组数据输出方式总数对10000取模的结果.
Sample Input
1
6 6
4 5 6 6 4 3
2 2 3 1 7 2
1 1 4 6 2 7
5 8 4 3 9 5
7 6 6 2 1 5
3 1 1 3 7 2
Sample Output
3948
Author
xhd
就是记忆化搜索,两个for枚举每个点可以到达的所有位置,自己1a的,但是写的有点卡,不顺畅,希望以后可以自己a题a的快一点。。。
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;
typedef long long ll;
const int Mod = 10000;
int dir[2][2] = {0,1,-1,0};
ll dp[105][105], sum;
int n, m, matrix[105][105], book[105][105];
int dfs(int x, int y, int limit)
{
if(dp[x][y]) return dp[x][y];
if(x == n && y == m)
{
return 1;
}
ll ans = 0;
for(int i = 0; i <= limit; i++) //这里要理解下
{
for(int j = 0; j <= limit - i; j++)
{
if(!i && !j) continue;
int tx = x + i;
int ty = y + j;
if(tx >= 1 && ty >= 1 && tx <= n && ty <= m)
{
ans = (ans + dfs(tx, ty, matrix[tx][ty]))%Mod;
}
}
}
return dp[x][y] = ans;
}
int main()
{
int t;
scanf("%d", &t);
while(t--)
{
memset(dp, 0, sizeof(dp));
scanf("%d%d", &n, &m);
for(int i = 1; i <= n; i++)
for(int j = 1; j <= m; j++)
scanf("%d", &matrix[i][j]);
dfs(1,1,matrix[1][1]);
printf("%lld\n", dp[1][1]);
}
return 0;
}
转载请注明原文地址: https://ju.6miu.com/read-676370.html