Specs satisfying the `Alamofire (~> 4.2.0)` dependency were found, but they required a higher minimu

    xiaoxiao2021-12-12  8

    podfile文件 

    platform :ios, ‘7.0’ use_frameworks! target “swift” do pod 'Alamofire', '~> 4.2.0' pod 'MJRefresh', '~> 3.1.12' pod 'SDWebImage', '~> 4.0.0-beta2' pod 'SVProgressHUD', '~> 2.0.4' end

    用pod install  时  报错 

     Invalid `Podfile` file: Unsupported platform `iOS`. Platform must be `:ios`, `:osx`, `:tvos`, or `:watchos`..

    原因是ios必须小写 'iOS '改成 ‘ios’

    [!] Unable to satisfy the following requirements:

    - `Alamofire (~> 4.2.0)` required by `Podfile`

    Specs satisfying the `Alamofire (~> 4.2.0)` dependency were found, but they required a higher minimum deployment target.

    原因是Alamofire4.0.0最低支持9.0  ,把 platform :ios, ‘7.0’  改成platform :ios, ‘9.0’,就OK 了。

    [!] The dependency `MBProgressHUD (~> 0.8)` is not used in any concrete target.

    原因是没有指定一个具体的target,把podfile文件格式改成最上边的那种就好。
    转载请注明原文地址: https://ju.6miu.com/read-900032.html

    最新回复(0)